extra.fix-8bit-in-cdf.patch 1005 B

123456789101112131415161718192021222324
  1. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  2. Date: 2014-03-05
  3. Description:
  4. Replace 8-bit characters in CDF summary data with spaces.
  5. .
  6. At the moment, uninitialized values are printed, resulting in
  7. differing results upon each call.
  8. .
  9. Present spaces instead until upstream provides a better solution.
  10. --- a/src/readcdf.c
  11. +++ b/src/readcdf.c
  12. @@ -141,8 +141,9 @@
  13. j++, s += k) {
  14. if (*s == '\0')
  15. break;
  16. - if (isprint((unsigned char)*s))
  17. - vbuf[j] = *s;
  18. + vbuf[j] =
  19. + isprint((unsigned char)*s) ?
  20. + *s : ' ';
  21. }
  22. if (j == sizeof(vbuf))
  23. --j;