113-magic-update-linuxext.patch 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. Author: Russell Coker <russell@coker.com.au>
  2. Description: Adding volume label and UUID support for linux ext (Closes: #489865).
  3. diff -Naurp file.orig/magic/Magdir/filesystems file/magic/Magdir/filesystems
  4. --- file.orig/magic/Magdir/filesystems 2008-07-02 13:47:23.000000000 +0000
  5. +++ file/magic/Magdir/filesystems 2008-07-15 14:21:39.000000000 +0000
  6. @@ -1027,6 +1027,8 @@
  7. # ext2/ext3 filesystems - Andreas Dilger <adilger@dilger.ca>
  8. # ext4 filesystem - Eric Sandeen <sandeen@sandeen.net>
  9. +# volume label and UUID Russell Coker
  10. +# http://etbe.coker.com.au/2008/07/08/label-vs-uuid-vs-device/
  11. 0x438 leshort 0xEF53 Linux
  12. >0x44c lelong x rev %d
  13. >0x43e leshort x \b.%d
  14. @@ -1042,25 +1044,32 @@
  15. # else large RO_COMPAT?
  16. >>>0x464 lelong >0x0000007 ext4 filesystem data
  17. # else large INCOMPAT?
  18. ->>0x460 lelong >0x000003f ext4 filesystem data
  19. +>>0x460 lelong >0x000003f ext4 filesystem data
  20. +>0x468 belong x \b, UUID=%08x
  21. +>0x46c beshort x \b-%04x
  22. +>0x46e beshort x \b-%04x
  23. +>0x470 beshort x \b-%04x
  24. +>0x472 belong x \b-%08x
  25. +>0x476 beshort x \b%04x
  26. +>0x478 string >0 \b, volume name "%s"
  27. # General flags for any ext* fs
  28. ->0x460 lelong &0x0000004 (needs journal recovery)
  29. ->0x43a leshort &0x0000002 (errors)
  30. +>0x460 lelong &0x0000004 (needs journal recovery)
  31. +>0x43a leshort &0x0000002 (errors)
  32. # INCOMPAT flags
  33. ->0x460 lelong &0x0000001 (compressed)
  34. -#>0x460 lelong &0x0000002 (filetype)
  35. -#>0x460 lelong &0x0000010 (meta bg)
  36. ->0x460 lelong &0x0000040 (extents)
  37. ->0x460 lelong &0x0000080 (64bit)
  38. -#>0x460 lelong &0x0000100 (mmp)
  39. -#>0x460 lelong &0x0000200 (flex bg)
  40. +>0x460 lelong &0x0000001 (compressed)
  41. +#>0x460 lelong &0x0000002 (filetype)
  42. +#>0x460 lelong &0x0000010 (meta bg)
  43. +>0x460 lelong &0x0000040 (extents)
  44. +>0x460 lelong &0x0000080 (64bit)
  45. +#>0x460 lelong &0x0000100 (mmp)
  46. +#>0x460 lelong &0x0000200 (flex bg)
  47. # RO_INCOMPAT flags
  48. -#>0x464 lelong &0x0000001 (sparse super)
  49. ->0x464 lelong &0x0000002 (large files)
  50. ->0x464 lelong &0x0000008 (huge files)
  51. -#>0x464 lelong &0x0000010 (gdt checksum)
  52. -#>0x464 lelong &0x0000020 (many subdirs)
  53. -#>0x463 lelong &0x0000040 (extra isize)
  54. +#>0x464 lelong &0x0000001 (sparse super)
  55. +>0x464 lelong &0x0000002 (large files)
  56. +>0x464 lelong &0x0000008 (huge files)
  57. +#>0x464 lelong &0x0000010 (gdt checksum)
  58. +#>0x464 lelong &0x0000020 (many subdirs)
  59. +#>0x463 lelong &0x0000040 (extra isize)
  60. # SGI disk labels - Nathan Scott <nathans@debian.org>
  61. 0 belong 0x0BE5A941 SGI disk label (volume header)