130-magic-update-psf2.patch 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. Author: Adam Buchbinder <adam.buchbinder@gmail.com>
  2. Description:
  3. Adding detection of PSF2 fonts (Closes: #492035).
  4. .
  5. Linux console fonts come in two formats; PSF1 is already detected, but
  6. PSF2, used for fonts which aren't 8-by-x shaped, was not. Add detection
  7. of these fonts, and make the output look similar to the PSF1 output,
  8. though with a different version number.
  9. .
  10. For more information, see:
  11. http://www.win.tue.nl/~aeb/linux/kbd/font-formats-1.html
  12. diff -Naurp file.orig/magic/Magdir/linux file/magic/Magdir/linux
  13. --- file.orig/magic/Magdir/linux 2010-07-13 18:21:11.561672573 +0200
  14. +++ file/magic/Magdir/linux 2010-07-13 18:23:37.790780191 +0200
  15. @@ -46,12 +46,21 @@
  16. 2 string LILO Linux/i386 LILO boot/chain loader
  17. #
  18. # PSF fonts, from H. Peter Anvin <hpa@yggdrasil.com>
  19. -0 leshort 0x0436 Linux/i386 PC Screen Font data,
  20. ->2 byte 0 256 characters, no directory,
  21. ->2 byte 1 512 characters, no directory,
  22. ->2 byte 2 256 characters, Unicode directory,
  23. ->2 byte 3 512 characters, Unicode directory,
  24. +# Updated by Adam Buchbinder <adam.buchbinder@gmail.com>
  25. +# See: http://www.win.tue.nl/~aeb/linux/kbd/font-formats-1.html
  26. +0 leshort 0x0436 Linux/i386 PC Screen Font v1 data,
  27. +>2 byte&0x01 0 256 characters,
  28. +>2 byte&0x01 !0 512 characters,
  29. +>2 byte&0x02 0 no directory,
  30. +>2 byte&0x02 !0 Unicode directory,
  31. >3 byte >0 8x%d
  32. +0 string \x72\xb5\x4a\x86\x00\x00 Linux/i386 PC Screen Font v2 data,
  33. +>16 lelong x %d characters,
  34. +>12 lelong&0x01 0 no directory,
  35. +>12 lelong&0x01 !0 Unicode directory,
  36. +>24 lelong x %d
  37. +>28 lelong x \bx%d
  38. +
  39. # Linux swap file, from Daniel Quinlan <quinlan@yggdrasil.com>
  40. 4086 string SWAP-SPACE Linux/i386 swap file
  41. # From: Jeff Bailey <jbailey@ubuntu.com>