235-magic-add-hdr.patch 1.1 KB

1234567891011121314151617181920212223242526
  1. Author: Adam Buchbinder <adam.buchbinder@gmail.com>
  2. Description: Adding new magics for HDR formats (Closes: #520416).
  3. diff -Naurp file.orig/magic/Magdir/images file/magic/Magdir/images
  4. --- file.orig/magic/Magdir/images 2009-12-05 18:35:08.000000000 +0100
  5. +++ file/magic/Magdir/images 2009-12-05 18:40:05.000000000 +0100
  6. @@ -639,3 +639,19 @@
  7. # Extension: .cpi
  8. # From: Alexander Danilov <alexander.a.danilov@gmail.com>
  9. 0 string HDMV0100 AVCHD Clip Information
  10. +
  11. +# From: Adam Buchbinder <adam.buchbinder@gmail.com>
  12. +# URL: http://local.wasp.uwa.edu.au/~pbourke/dataformats/pic/
  13. +# Radiance HDR; usually has .pic or .hdr extension.
  14. +0 string #?RADIANCE\n Radiance HDR image data
  15. +#!mime image/vnd.radiance
  16. +
  17. +# From: Adam Buchbinder <adam.buchbinder@gmail.com>
  18. +# URL: http://www.mpi-inf.mpg.de/resources/pfstools/pfs_format_spec.pdf
  19. +# Used by the pfstools packages. The regex matches for the image size could
  20. +# probably use some work. The MIME type is made up; if there's one in
  21. +# actual common use, it should replace the one below.
  22. +0 string PFS1\x0a PFS HDR image data
  23. +#!mime image/x-pfs
  24. +>1 regex [0-9]*\ \b, %s
  25. +>>1 regex \ [0-9]{4} \bx%s