1234567891011121314151617181920212223242526272829303132 |
- Author: Adam Buchbinder <adam.buchbinder@gmail.com>
- Description: Adding new magics for Canon CRW and CR2 files (Closes: #516054).
- diff -Naurp file.orig/magic/Magdir/images file/magic/Magdir/images
- --- file.orig/magic/Magdir/images 2010-07-13 18:47:51.670671838 +0200
- +++ file/magic/Magdir/images 2010-07-13 18:48:12.525672541 +0200
- @@ -63,6 +63,25 @@
- 0 string IIN1 NIFF image data
- !:mime image/x-niff
-
- +# Canon RAW version 1 (CRW) files are a type of Canon Image File Format
- +# (CIFF) file. These are apparently all little-endian.
- +# From: Adam Buchbinder <adam.buchbinder@gmail.com>
- +# URL: http://www.sno.phy.queensu.ca/~phil/exiftool/canon_raw.html
- +0 string II\x1a\0\0\0HEAPCCDR Canon CIFF raw image data
- +!:mime image/x-canon-crw
- +>16 leshort x \b, version %d.
- +>14 leshort x \b%d
- +
- +# Canon RAW version 2 (CR2) files are a kind of TIFF with an extra magic
- +# number. Put this above the TIFF test to make sure we detect them.
- +# These are apparently all little-endian.
- +# From: Adam Buchbinder <adam.buchbinder@gmail.com>
- +# URL: http://libopenraw.freedesktop.org/wiki/Canon_CR2
- +0 string II\x2a\0\x10\0\0\0CR Canon CR2 raw image data
- +!:mime image/x-canon-cr2
- +>10 byte x \b, version %d.
- +>11 byte x \b%d
- +
- # Tag Image File Format, from Daniel Quinlan (quinlan@yggdrasil.com)
- # The second word of TIFF files is the TIFF version number, 42, which has
- # never changed. The TIFF specification recommends testing for it.
|