cherry-pick.FILE5_37-50-g2a1bb655.always-support-the-no-sandbox-option.patch 791 B

12345678910111213141516171819202122232425262728293031
  1. Subject: Always support the --no-sandbox option
  2. Origin: FILE5_37-50-g2a1bb655 <https://github.com/file/file/commit/FILE5_37-50-g2a1bb655>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Sat Jul 13 16:23:58 2019 +0000
  5. --- a/src/file.c
  6. +++ b/src/file.c
  7. @@ -297,11 +297,11 @@
  8. case 's':
  9. flags |= MAGIC_DEVICES;
  10. break;
  11. -#ifdef HAVE_LIBSECCOMP
  12. case 'S':
  13. +#ifdef HAVE_LIBSECCOMP
  14. sandbox = 0;
  15. - break;
  16. #endif
  17. + break;
  18. case 'v':
  19. if (magicfile == NULL)
  20. magicfile = magic_getpath(magicfile, action);
  21. @@ -309,6 +309,9 @@
  22. VERSION);
  23. (void)fprintf(stdout, "magic file from %s\n",
  24. magicfile);
  25. +#ifdef HAVE_LIBSECCOMP
  26. + (void)fprintf(stdout, "seccomp support included\n");
  27. +#endif
  28. return 0;
  29. case 'z':
  30. flags |= MAGIC_COMPRESS;