101-magic-remove-awk.dpatch 1.0 KB

12345678910111213141516171819202122
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 101-magic-remove-awk.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: Remove AWK detection by regular expression testing just for 'BEGIN:';
  5. ## DP: this caused a lot of false guesses (and problems with naughty programs
  6. ## DP: reading other programs' files), this closes: #308305, #375403 and makes
  7. ## DP: others disappear (for the time being, for example, it closes: #375722).
  8. @DPATCH@
  9. diff -Naur file-4.20.orig/magic/Magdir/commands file-4.20/magic/Magdir/commands
  10. --- file-4.20.orig/magic/Magdir/commands 2007-01-19 19:28:01.000000000 +0000
  11. +++ file-4.20/magic/Magdir/commands 2007-03-27 12:23:14.000000000 +0000
  12. @@ -28,7 +28,7 @@
  13. 0 string/b #!\ /bin/awk awk script text executable
  14. 0 string/b #!\ /usr/bin/awk awk script text executable
  15. # update to distinguish from *.vcf files
  16. -0 regex BEGIN[[:space:]]*[{] awk script text
  17. +#0 regex BEGIN[[:space:]]*[{] awk script text
  18. # AT&T Bell Labs' Plan 9 shell
  19. 0 string/b #!\ /bin/rc Plan 9 rc shell script text executable