303-magic-add-clarion.dpatch 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 302-magic-add-clarion.dpatch by Julien Blache <jblache@debian.org>
  3. ##
  4. ## DP: New magic for the Clarion files (Closes: #282680).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/clarion file-4.20/magic/Magdir/clarion
  7. --- file-4.20.orig/magic/Magdir/clarion 1970-01-01 00:00:00.000000000 +0000
  8. +++ file-4.20/magic/Magdir/clarion 2007-03-27 17:07:02.000000000 +0000
  9. @@ -0,0 +1,29 @@
  10. +#
  11. +# Magic numbers for the Clarion Personal/Professional Developer (v2 and above) files
  12. +#
  13. +# Julien BLACHE <jb@jblache.org>
  14. +#
  15. +
  16. +#### Database and associated files
  17. +
  18. +### Database files
  19. +## signature
  20. +0 leshort 0x3343 Clarion Personal/Professional Developer (v2 and above) data file
  21. +## interesting attributes
  22. +>2 leshort &0x0001 \b, locked
  23. +>2 leshort &0x0004 \b, encrypted
  24. +>2 leshort &0x0008 \b, memo file exists
  25. +>2 leshort &0x0010 \b, compressed
  26. +>2 leshort &0x0040 \b, read only
  27. +## number of records
  28. +>5 lelong x \b, %ld records
  29. +
  30. +### Memo files
  31. +0 leshort 0x334d Clarion Personal/Professional Developer (v2 and above) memo data
  32. +
  33. +### Key/Index files
  34. +## No magic ? :(
  35. +
  36. +
  37. +#### Help files
  38. +0 leshort 0x49e0 Clarion Personal/Professional Developer (v2 and above) help data
  39. diff -Naur file-4.20.orig/magic/Makefile.am file-4.20/magic/Makefile.am
  40. --- file-4.20.orig/magic/Makefile.am 2006-11-25 18:36:10.000000000 +0000
  41. +++ file-4.20/magic/Makefile.am 2007-03-27 17:07:26.000000000 +0000
  42. @@ -60,6 +60,7 @@
  43. Magdir/cisco \
  44. Magdir/citrus \
  45. Magdir/claris \
  46. +Magdir/clarion \
  47. Magdir/clipper \
  48. Magdir/cracklib \
  49. Magdir/spec \
  50. diff -Naur file-4.20.orig/magic/Makefile.in file-4.20/magic/Makefile.in
  51. --- file-4.20.orig/magic/Makefile.in 2007-03-01 23:21:09.000000000 +0000
  52. +++ file-4.20/magic/Makefile.in 2007-03-27 17:07:32.000000000 +0000
  53. @@ -200,6 +200,7 @@
  54. Magdir/cisco \
  55. Magdir/citrus \
  56. Magdir/claris \
  57. +Magdir/clarion \
  58. Magdir/clipper \
  59. Magdir/cracklib \
  60. Magdir/spec \