998-doc-manpages.dpatch 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 95-doc-manpages.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: FIXME
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/doc/file.man file-4.20/doc/file.man
  7. --- file-4.20.orig/doc/file.man 2007-01-25 21:05:46.000000000 +0000
  8. +++ file-4.20/doc/file.man 2007-03-27 12:23:14.000000000 +0000
  9. @@ -47,9 +47,8 @@
  10. or non-printable).
  11. Exceptions are well-known file formats (core files, tar archives)
  12. that are known to contain binary data.
  13. -When modifying the file
  14. -.Pa __MAGIC__
  15. -or the program itself, make sure to
  16. +When adding local definitions to
  17. +.Pa /etc/magic ,
  18. .Em "preserve these keywords" .
  19. People depend on knowing that all the readable files in a directory
  20. have the word
  21. @@ -99,12 +98,14 @@
  22. has been applied by extension to data files.
  23. Any file with some invariant identifier at a small fixed
  24. offset into the file can usually be described in this way.
  25. -The information identifying these files is read from the compiled
  26. +The information identifying these files is read from
  27. +.Pa /etc/magic
  28. +and the compiled
  29. magic file
  30. .Pa __MAGIC__.mgc ,
  31. or
  32. .Pa __MAGIC__
  33. -if the compile file does not exist. In addition
  34. +if the compiled file does not exist. In addition
  35. .Nm
  36. will look in
  37. .Pa $HOME/.magic.mgc ,
  38. @@ -161,7 +162,8 @@
  39. archives).
  40. .Pp
  41. Any file that cannot be identified as having been written
  42. -in any of the character sets listed above is simply said to be ``data''.
  43. +in any of the character sets listed above is simply said to be
  44. +.Dq data .
  45. .Sh OPTIONS
  46. .Bl -tag -width indent
  47. .It Fl b , -brief
  48. @@ -239,7 +241,12 @@
  49. .Dq FILES
  50. section, below).
  51. .It Fl k , -keep-going
  52. -Don't stop at the first match, keep going.
  53. +Don't stop at the first match, keep going. Subsequent matches will be
  54. +prepended by
  55. +.Dq "\[rs]012\- ".
  56. +(If you want a newline, see
  57. +.Dq "\-r"
  58. +option.)
  59. .It Fl L , -dereference
  60. option causes symlinks to be followed, as the like-named option in
  61. .Xr ls 1
  62. @@ -252,7 +259,8 @@
  63. This can be a single file, or a colon-separated list of files.
  64. If a compiled magic file is found alongside, it will be used instead.
  65. With the
  66. -.Fl i or
  67. +.Fl i
  68. +or
  69. .Fl "mime"
  70. option, the program adds
  71. .Dq .mime
  72. @@ -339,6 +347,11 @@
  73. and/or
  74. .Dq .mgc
  75. to the value of this variable as appropriate.
  76. +However,
  77. +.Pa file
  78. +has to exist in order for
  79. +.Pa file.mime
  80. +to be considered.
  81. The environment variable
  82. .Dv POSIXLY_CORRECT
  83. controls (on systems that support symbolic links), if
  84. @@ -413,12 +426,6 @@
  85. The order of entries in the magic file is significant.
  86. Depending on what system you are using, the order that
  87. they are put together may be incorrect.
  88. -If your old
  89. -.Nm
  90. -command uses a magic file,
  91. -keep the old magic file around for comparison purposes
  92. -(rename it to
  93. -.Pa __MAGIC__.orig ).
  94. .Sh EXAMPLES
  95. .Bd -literal -offset indent
  96. $ file file.c file /dev/{wd0a,hda}
  97. @@ -586,9 +593,17 @@
  98. The new support for multiple character codes makes it even slower.
  99. .Pp
  100. This manual page, and particularly this section, is too long.
  101. +.Sh RETURN CODE
  102. +.Nm
  103. +almost always returns 0. It returns a different code if it cannot open a file.
  104. .Sh AVAILABILITY
  105. You can obtain the original author's latest version by anonymous FTP
  106. on
  107. .Dv ftp.astron.com
  108. in the directory
  109. .Dv /pub/file/file-X.YZ.tar.gz
  110. +.Pp
  111. +This Debian version adds a number of new magix entries. It can be
  112. +obtained from every site carrying a Debian distribution (that is
  113. +.Dv ftp.debian.org
  114. +and mirrors).
  115. diff -Naur file-4.20.orig/doc/libmagic.man file-4.20/doc/libmagic.man
  116. --- file-4.20.orig/doc/libmagic.man 2007-01-25 21:04:08.000000000 +0000
  117. +++ file-4.20/doc/libmagic.man 2007-03-27 12:23:14.000000000 +0000
  118. @@ -39,7 +39,7 @@
  119. .Nm magic_load
  120. .Nd Magic number recognition library.
  121. .Sh LIBRARY
  122. -.Lb libmagic
  123. +.Lb libmagic1
  124. .Sh SYNOPSIS
  125. .In magic.h
  126. .Ft magic_t
  127. diff -Naur file-4.20.orig/doc/magic.man file-4.20/doc/magic.man
  128. --- file-4.20.orig/doc/magic.man 2007-01-12 17:38:27.000000000 +0000
  129. +++ file-4.20/doc/magic.man 2007-03-27 12:23:14.000000000 +0000
  130. @@ -65,7 +65,7 @@
  131. .Dq c
  132. flag, specifies case insensitive matching: lowercase
  133. characters in the magic match both lower and upper case characters in the
  134. -targer, whereas upper case characters in the magic, only much uppercase
  135. +target, whereas upper case characters in the magic, only much uppercase
  136. characters in the target.
  137. .It Dv pstring
  138. A pascal style string where the first byte is interpreted as the an