319-magic-add-ocfs.dpatch 1.2 KB

1234567891011121314151617181920212223242526272829303132
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 317-magic-add-ocfs.dpatch by Aaron Botsis <redhat@digitalmafia.org>
  3. ##
  4. ## DP: New magic for the Oracle Clustered Filesystem.
  5. @DPATCH@
  6. diff -Naur file-4.21.orig/magic/Magdir/filesystems file-4.21/magic/Magdir/filesystems
  7. --- file-4.21.orig/magic/Magdir/filesystems 2007-05-16 00:02:54.000000000 +0000
  8. +++ file-4.21/magic/Magdir/filesystems 2007-06-01 18:46:57.000000000 +0000
  9. @@ -1185,6 +1185,21 @@
  10. >>>>>>>>&0 bedate =0 full dump
  11. >>>>>>>>&0 bedate !0 incremental since: %s
  12. +# Type: Oracle Clustered Filesystem
  13. +# From: Aaron Botsis <redhat@digitalmafia.org>
  14. +8 string OracleCFS Oracle Clustered Filesystem,
  15. +>4 long x rev %d
  16. +>0 long x \b.%d,
  17. +>560 string x label: %.64s,
  18. +>136 string x mountpoint: %.128s
  19. +
  20. +# Type: Oracle ASM tagged volume
  21. +# From: Aaron Botsis <redhat@digitalmafia.org>
  22. +32 string ORCLDISK Oracle ASM Volume,
  23. +>40 string x Disk Name: %0.12s
  24. +32 string ORCLCLRD Oracle ASM Volume (cleared),
  25. +>40 string x Disk Name: %0.12s
  26. +
  27. #----------------------------------------------------------
  28. # VMS backup savesets - gerardo.cacciari@gmail.com
  29. #