327-magic-add-snes.dpatch 938 B

1234567891011121314151617181920212223242526
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 324-magic-add-snes.dpatch by Josh Triplett <josh@freedesktop.org>
  3. ##
  4. ## DP: New magic for SNES SPC700 sound files (Closes: #410847).
  5. @DPATCH@
  6. diff -Naur file-4.21.orig/magic/Magdir/audio file-4.21/magic/Magdir/audio
  7. --- file-4.21.orig/magic/Magdir/audio 2007-12-23 17:32:42.000000000 +0000
  8. +++ file-4.21/magic/Magdir/audio 2007-12-23 17:33:57.000000000 +0000
  9. @@ -268,6 +268,15 @@
  10. >122 byte&0x1 =1 PAL
  11. >122 byte&0x1 =0 NTSC
  12. +# Type: SNES SPC700 sound files
  13. +# From: Josh Triplett <josh@freedesktop.org>
  14. +0 string SNES-SPC700\ Sound\ File\ Data\ v SNES SPC700 sound file
  15. +>&0 string 0.30 \b, version %s
  16. +>>0x23 byte 0x1B \b, without ID666 tag
  17. +>>0x23 byte 0x1A \b, with ID666 tag
  18. +>>>0x2E string >\0 \b, song "%.32s"
  19. +>>>0x4E string >\0 \b, game "%.32s"
  20. +
  21. # Impulse tracker module (audio/x-it)
  22. 0 string IMPM Impulse Tracker module sound data -
  23. >4 string >\0 "%s"