333-magic-add-xen.dpatch 660 B

1234567891011121314151617181920
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 328-magic-add-xen.dpatch by Radek Vokal <rvokal@redhat.com>
  3. ##
  4. ## DP: xen patch, recognizes Xen saved domain
  5. @DPATCH@
  6. diff -Naur file-4.21.orig/magic/Magdir/linux file-4.21/magic/Magdir/linux
  7. --- file-4.21.orig/magic/Magdir/linux 2007-04-23 14:32:39.000000000 +0000
  8. +++ file-4.21/magic/Magdir/linux 2007-06-01 19:00:29.000000000 +0000
  9. @@ -246,3 +246,9 @@
  10. >72 string x %s]
  11. >168 string x UUID: %s
  12. +# Type: Xen, the virtual machine monitor
  13. +# From: Radek Vokal <rvokal@redhat.com>
  14. +0 string LinuxGuestRecord Xen saved domain
  15. +#>2 regex \(name\ [^)]*\) %s
  16. +>20 search/256 (name (name
  17. +>>&1 string x %s...)