903-file-localmagic.dpatch 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 903-magic-local.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: No longer includes Localstuff in /usr/share/misc/magic. Local definitions
  5. ## DP: should go to /etc/magic.
  6. @DPATCH@
  7. diff -Naurp file-4.24.orig/magic/Header file-4.24/magic/Header
  8. --- file-4.24.orig/magic/Header 2000-08-05 17:36:46.000000000 +0000
  9. +++ file-4.24/magic/Header 2008-04-07 08:17:11.000000000 +0000
  10. @@ -1,5 +1,5 @@
  11. -# Magic
  12. # Magic data for file(1) command.
  13. -# Machine-generated from src/cmd/file/magdir/*; edit there only!
  14. -# Format is described in magic(files), where:
  15. -# files is 5 on V7 and BSD, 4 on SV, and ?? in the SVID.
  16. +# Format is described in magic(5).
  17. +# Don't edit this file, edit /etc/magic or send your suggested inclusions to
  18. +# this file as a wishlist bug against file (using the reportbug utility).
  19. +
  20. diff -Naurp file-4.24.orig/magic/magic.local file-4.24/magic/magic.local
  21. --- file-4.24.orig/magic/magic.local 1970-01-01 00:00:00.000000000 +0000
  22. +++ file-4.24/magic/magic.local 2008-04-07 08:17:11.000000000 +0000
  23. @@ -0,0 +1,3 @@
  24. +# Magic local data for file(1) command.
  25. +# Insert here your local magic data. Format is described in magic(5).
  26. +
  27. diff -Naurp file-4.24.orig/src/Makefile.am file-4.24/src/Makefile.am
  28. --- file-4.24.orig/src/Makefile.am 2008-02-24 01:33:05.000000000 +0000
  29. +++ file-4.24/src/Makefile.am 2008-04-07 08:16:39.000000000 +0000
  30. @@ -5,7 +5,7 @@ EXTRA_DIST = getopt_long.c
  31. bin_PROGRAMS = file
  32. -AM_CPPFLAGS = -DMAGIC='"$(MAGIC)"'
  33. +AM_CPPFLAGS = -DMAGIC='"/etc/magic:$(MAGIC)"'
  34. libmagic_la_SOURCES = magic.c apprentice.c softmagic.c ascmagic.c \
  35. compress.c is_tar.c readelf.c print.c fsmagic.c \
  36. diff -Naurp file-4.24.orig/src/Makefile.in file-4.24/src/Makefile.in
  37. --- file-4.24.orig/src/Makefile.in 2008-03-22 21:40:13.000000000 +0000
  38. +++ file-4.24/src/Makefile.in 2008-04-07 08:16:47.000000000 +0000
  39. @@ -198,7 +198,7 @@ MAGIC = $(pkgdatadir)/magic
  40. lib_LTLIBRARIES = libmagic.la
  41. include_HEADERS = magic.h
  42. EXTRA_DIST = getopt_long.c
  43. -AM_CPPFLAGS = -DMAGIC='"$(MAGIC)"'
  44. +AM_CPPFLAGS = -DMAGIC='"/etc/magic:$(MAGIC)"'
  45. libmagic_la_SOURCES = magic.c apprentice.c softmagic.c ascmagic.c \
  46. compress.c is_tar.c readelf.c print.c fsmagic.c \
  47. funcs.c file.h names.h patchlevel.h readelf.h tar.h apptype.c \