998-doc-manpages.dpatch 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 998-doc-manpages.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: FIXME, and #417511.
  5. @DPATCH@
  6. diff -Naurp file-4.24.orig/doc/file.man file-4.24/doc/file.man
  7. --- file-4.24.orig/doc/file.man 2008-03-07 15:00:07.000000000 +0000
  8. +++ file-4.24/doc/file.man 2008-04-07 08:26:06.000000000 +0000
  9. @@ -51,7 +51,7 @@ meaning anything else (data is usually
  10. or non-printable).
  11. Exceptions are well-known file formats (core files, tar archives)
  12. that are known to contain binary data.
  13. -When modifying magic files or the program itself, make sure to
  14. +When adding local definitions to /etc/magic, make sure to
  15. .Em "preserve these keywords" .
  16. Users depend on knowing that all the readable files in a directory
  17. have the word
  18. @@ -95,7 +95,8 @@ The concept of a
  19. has been applied by extension to data files.
  20. Any file with some invariant identifier at a small fixed
  21. offset into the file can usually be described in this way.
  22. -The information identifying these files is read from the compiled
  23. +The information identifying these files is read from /etc/magic
  24. +and the the compiled
  25. magic file
  26. .Pa __MAGIC__.mgc ,
  27. or the files in the directory
  28. @@ -326,6 +327,11 @@ will not attempt to open
  29. adds
  30. .Dq .mgc
  31. to the value of this variable as appropriate.
  32. +However,
  33. +.Pa file
  34. +has to exist in order for
  35. +.Pa file.mime
  36. +to be considered.
  37. The environment variable
  38. .Dv POSIXLY_CORRECT
  39. controls (on systems that support symbolic links), whether
  40. @@ -401,12 +407,6 @@ will be distributed periodically.
  41. The order of entries in the magic file is significant.
  42. Depending on what system you are using, the order that
  43. they are put together may be incorrect.
  44. -If your old
  45. -.Nm
  46. -command uses a magic file,
  47. -keep the old magic file around for comparison purposes
  48. -(rename it to
  49. -.Pa __MAGIC__.orig ).
  50. .Sh EXAMPLES
  51. .Bd -literal -offset indent
  52. $ file file.c file /dev/{wd0a,hda}
  53. @@ -548,3 +548,8 @@ on
  54. .Dv ftp.astron.com
  55. in the directory
  56. .Dv /pub/file/file-X.YZ.tar.gz
  57. +.Pp
  58. +This Debian version adds a number of new magix entries. It can be
  59. +obtained from every site carrying a Debian distribution (that is
  60. +.Dv ftp.debian.org
  61. +and mirrors).