999-conglomeration.dpatch 580 B

1234567891011121314151617181920
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 999-conglomeration.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: Needs to be broken out (FIXME).
  5. @DPATCH@
  6. diff -Naurp file-4.24.orig/src/fsmagic.c file-4.24/src/fsmagic.c
  7. --- file-4.24.orig/src/fsmagic.c 2008-02-14 20:14:52.000000000 +0000
  8. +++ file-4.24/src/fsmagic.c 2008-04-07 08:32:13.000000000 +0000
  9. @@ -110,7 +110,8 @@ file_fsmagic(struct magic_set *ms, const
  10. if (file_printf(ms, "cannot open `%s' (%s)",
  11. fn, strerror(errno)) == -1)
  12. return -1;
  13. - return 1;
  14. + ms->haderr++;
  15. + return -1;
  16. }
  17. if (mime) {