12345678910111213141516171819202122 |
- Subject: Check file_printf()
- Origin: FILE5_34-18-gbd8fafe3 <https://github.com/file/file/commit/FILE5_34-18-gbd8fafe3>
- Upstream-Author: Christos Zoulas <christos@zoulas.com>
- Date: Wed Aug 1 10:09:47 2018 +0000
- --- a/src/readelf.c
- +++ b/src/readelf.c
- @@ -545,9 +545,11 @@
- size_t noff, size_t doff, int *flags)
- {
- if (namesz == 5 && strcmp((char *)&nbuf[noff], "SuSE") == 0 &&
- - type == NT_GNU_VERSION && descsz == 2) {
- - *flags |= FLAGS_DID_OS_NOTE;
- - file_printf(ms, ", for SuSE %d.%d", nbuf[doff], nbuf[doff + 1]);
- + type == NT_GNU_VERSION && descsz == 2) {
- + *flags |= FLAGS_DID_OS_NOTE;
- + if (file_printf(ms, ", for SuSE %d.%d", nbuf[doff],
- + nbuf[doff + 1]) == -1)
- + return -1;
- return 1;
- }
-
|