1234567891011121314151617 |
- Subject: Appease coverity by calling umask around mkstemp(3)
- Origin: FILE5_34-19-gfda25acb <https://github.com/file/file/commit/FILE5_34-19-gfda25acb>
- Upstream-Author: Christos Zoulas <christos@zoulas.com>
- Date: Wed Aug 1 10:11:16 2018 +0000
- --- a/src/compress.c
- +++ b/src/compress.c
- @@ -397,7 +397,9 @@
- #else
- {
- int te;
- + int ou = umask(0);
- tfd = mkstemp(buf);
- + (void)umask(ou);
- te = errno;
- (void)unlink(buf);
- errno = te;
|