202-magic-update-awk.dpatch 694 B

123456789101112131415161718
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 202-magic-update-awk.dpatch by Werner Fink <werner@suse.de>
  3. ##
  4. ## DP: Updates (and re-enables) awk magic.
  5. @DPATCH@
  6. diff -Naurp file-4.24.orig/magic/Magdir/commands file-4.24/magic/Magdir/commands
  7. --- file-4.24.orig/magic/Magdir/commands 2008-05-04 14:12:49.000000000 +0000
  8. +++ file-4.24/magic/Magdir/commands 2008-05-21 09:36:15.000000000 +0000
  9. @@ -49,6 +49,7 @@
  10. # update to distinguish from *.vcf files
  11. # this is broken because postscript has /EBEGIN{ for example.
  12. #0 search/Bb BEGIN { awk script text
  13. +0 regex =^\\s*BEGIN\\s*[{] awk script text
  14. # AT&T Bell Labs' Plan 9 shell
  15. 0 string/b #!\ /bin/rc Plan 9 rc shell script text executable