333-magic-add-xen.dpatch 661 B

1234567891011121314151617181920
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 328-magic-add-xen.dpatch by Radek Vokal <rvokal@redhat.com>
  3. ##
  4. ## DP: xen patch, recognizes Xen saved domain
  5. @DPATCH@
  6. diff -Naurp file-4.23.orig/magic/Magdir/linux file-4.23/magic/Magdir/linux
  7. --- file-4.23.orig/magic/Magdir/linux 2008-01-12 17:47:04.000000000 +0000
  8. +++ file-4.23/magic/Magdir/linux 2008-01-12 17:46:42.000000000 +0000
  9. @@ -248,3 +248,9 @@
  10. >72 string x %s]
  11. >168 string x UUID: %s
  12. +# Type: Xen, the virtual machine monitor
  13. +# From: Radek Vokal <rvokal@redhat.com>
  14. +0 string LinuxGuestRecord Xen saved domain
  15. +#>2 regex \(name\ [^)]*\) %s
  16. +>20 search/256 (name (name
  17. +>>&1 string x %s...)