906-file-hurd.dpatch 597 B

12345678910111213141516171819202122
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 906-file-hurd.dpatch by Michael Casadevall <sonicmctails@gmail.com>
  3. ##
  4. ## DP: Fixes a FTBFS on hurd (Closes: #433716).
  5. @DPATCH@
  6. diff -Naur file-4.21.orig/src/magic.c file-4.21/src/magic.c
  7. --- file-4.21.orig/src/magic.c 2007-03-26 17:59:50.000000000 +0000
  8. +++ file-4.21/src/magic.c 2007-07-19 06:25:16.000000000 +0000
  9. @@ -58,6 +58,11 @@
  10. #include <locale.h>
  11. #endif
  12. +#ifndef PIPE_BUF
  13. +// Get the PIPE_BUF from pathconf
  14. +#define PIPE_BUF pathconf(".", _PC_PIPE_BUF)
  15. +#endif
  16. +
  17. #include <netinet/in.h> /* for byte swapping */
  18. #include "patchlevel.h"