0003-file-usage.patch 917 B

1234567891011121314151617
  1. Author: Daniel Baumann <mail@daniel-baumann.ch>
  2. Description: Adding POSIXLY_CORRECT reference in usage message (Closes: #576679).
  3. diff -Naurp file.orig/src/file_opts.h file/src/file_opts.h
  4. --- file.orig/src/file_opts.h
  5. +++ file/src/file_opts.h
  6. @@ -34,8 +34,8 @@ OPT_LONGONLY("mime-encoding", 0, "
  7. OPT('k', "keep-going", 0, " don't stop at the first match\n")
  8. #ifdef S_IFLNK
  9. OPT('l', "list", 0, " list magic strength\n")
  10. -OPT('L', "dereference", 0, " follow symlinks (default)\n")
  11. -OPT('h', "no-dereference", 0, " don't follow symlinks\n")
  12. +OPT('L', "dereference", 0, " follow symlinks (default if POSIXLY_CORRECT is set)\n")
  13. +OPT('h', "no-dereference", 0, " don't follow symlinks (default if POSIXLY_CORRECT is not set)\n")
  14. #endif
  15. OPT('n', "no-buffer", 0, " do not buffer output\n")
  16. OPT('N', "no-pad", 0, " do not pad output\n")