0010-mdadm.patch 915 B

1234567891011121314151617181920212223242526272829303132
  1. Author: Russell Coker <russell@coker.com.au>
  2. Description: Adding new magics for Linux Software RAID (Closes: #663454).
  3. diff -Naurp file.orig/magic/Magdir/linux file/magic/Magdir/linux
  4. --- file.orig/magic/Magdir/linux
  5. +++ file/magic/Magdir/linux
  6. @@ -344,3 +344,25 @@
  7. #>2 regex \(name\ [^)]*\) %s
  8. >20 search/256 (name (name
  9. >>&1 string x %s...)
  10. +
  11. +# Linux Software RAID (mdadm)
  12. +# Russell Coker <russell@coker.com.au>
  13. +4096 lelong 0xa92b4efc Linux Software RAID
  14. +>4100 lelong x version 1.2 (%d)
  15. +>4112 belong x UUID=%8x:
  16. +>4116 belong x \b%8x:
  17. +>4120 belong x \b%8x:
  18. +>4124 belong x \b%8x
  19. +>4128 string x name=%s
  20. +>4168 lelong x level=%d
  21. +>4188 lelong x disks=%d
  22. +
  23. +0 lelong 0xa92b4efc Linux Software RAID
  24. +>4 lelong x version 1.1 (%d)
  25. +>16 belong x UUID=%8x:
  26. +>20 belong x \b%8x:
  27. +>24 belong x \b%8x:
  28. +>28 belong x \b%8x
  29. +>32 string x name=%s
  30. +>72 lelong x level=%d
  31. +>92 lelong x disks=%d