123456789101112131415161718 |
- Subject: Free memory on error
- Origin: FILE5_30-30-gc703aa9f
- Upstream-Author: Christos Zoulas <christos@zoulas.com>
- Date: Tue Mar 28 15:13:07 2017 +0000
- --- a/src/cdf.c
- +++ b/src/cdf.c
- @@ -1057,6 +1057,10 @@
- }
- return 0;
- out:
- + free(*info);
- + *info = NULL;
- + *count = 0;
- + *maxcount = 0;
- errno = EFTYPE;
- return -1;
- }
|