cherry-pick.FILE5_19-18-g0641e56.CVE-2014-3587.patch 784 B

123456789101112131415161718192021222324
  1. Subject: Integer overflow in the cdf_read_property_info function allows remote attackers to cause a denial of service
  2. ID: CVE-2014-3587
  3. Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Thu Aug 7 09:38:35 2014 +0000
  5. Origin:
  6. commit 0641e56be1af003aa02c7c6b0184466540637233
  7. Debian-Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  8. Last-Update: 2014-09-07
  9. Prevent wrap around (Remi Collet at redhat)
  10. --- a/src/cdf.c
  11. +++ b/src/cdf.c
  12. @@ -824,6 +824,10 @@ cdf_read_property_info(const cdf_stream_
  13. q = (const uint8_t *)(const void *)
  14. ((const char *)(const void *)p + ofs
  15. - 2 * sizeof(uint32_t));
  16. + if (q < p) {
  17. + DPRINTF(("Wrapped around %p < %p\n", q, p));
  18. + goto out;
  19. + }
  20. if (q > e) {
  21. DPRINTF(("Ran of the end %p > %p\n", q, e));
  22. goto out;