123456789101112131415161718192021222324252627282930313233343536373839404142434445 |
- #!/bin/sh /usr/share/dpatch/dpatch-run
- ## 105-magic-remove-com.dpatch by Michael Piefel <piefel@debian.org>
- ##
- ## DP: Disable one-byte magic for COM (closes: #393775, #339618).
- @DPATCH@
- diff -Naur file-4.20.orig/magic/Magdir/msdos file-4.20/magic/Magdir/msdos
- --- file-4.20.orig/magic/Magdir/msdos 2007-01-19 19:35:20.000000000 +0000
- +++ file-4.20/magic/Magdir/msdos 2007-04-03 12:32:00.000000000 +0000
- @@ -262,8 +262,8 @@
- # Uncommenting only the first two lines will cover about 2/3 of COM files,
- # but it isn't feasible to match all COM files since there must be at least
- # two dozen different one-byte "magics".
- -0 byte 0xe9 DOS executable (COM)
- ->0x1FE leshort 0xAA55 \b, boot code
- +#0 byte 0xe9 DOS executable (COM)
- +#>0x1FE leshort 0xAA55 \b, boot code
- >6 string SFX\ of\ LHarc (%s)
- 0 belong 0xffffffff DOS executable (device driver)
- #CMD640X2.SYS
- @@ -286,15 +286,15 @@
- >>77 string >\x40
- >>>77 string <\x5B
- >>>>77 string x \b, name: %.8s
- -0 byte 0x8c DOS executable (COM)
- +#0 byte 0x8c DOS executable (COM)
- # 0xeb conflicts with "sequent" magic
- -0 byte 0xeb DOS executable (COM)
- ->0x1FE leshort 0xAA55 \b, boot code
- ->85 string UPX \b, UPX compressed
- ->4 string \ $ARX \b, ARX self-extracting archive
- ->4 string \ $LHarc \b, LHarc self-extracting archive
- ->0x20e string SFX\ by\ LARC \b, LARC self-extracting archive
- -0 byte 0xb8 COM executable
- +#0 byte 0xeb DOS executable (COM)
- +#>0x1FE leshort 0xAA55 \b, boot code
- +#>85 string UPX \b, UPX compressed
- +#>4 string \ $ARX \b, ARX self-extracting archive
- +#>4 string \ $LHarc \b, LHarc self-extracting archive
- +#>0x20e string SFX\ by\ LARC \b, LARC self-extracting archive
- +#0 byte 0xb8 COM executable
- # modified by Joerg Jenderek
- >1 lelong !0x21cd4cff for DOS
- # http://syslinux.zytor.com/comboot.php
|