106-magic-remove-emf.dpatch 1.5 KB

12345678910111213141516171819202122232425262728293031323334
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 106-magic-remove-emf.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: Disabled EMF detection as it not only caused false positives, which might
  5. ## DP: have been acceptible, but a segmentation fault (closes: #333502).
  6. @DPATCH@
  7. diff -Naurp file-4.23.orig/magic/Magdir/msdos file-4.23/magic/Magdir/msdos
  8. --- file-4.23.orig/magic/Magdir/msdos 2007-12-28 15:14:13.000000000 +0000
  9. +++ file-4.23/magic/Magdir/msdos 2008-01-12 16:33:00.000000000 +0000
  10. @@ -580,17 +580,17 @@
  11. # syntax available by some file commands you could write:
  12. # 0 lelong 1
  13. # &40 ulelong 0x464D4520 Windows Enhanced Metafile (EMF) image data
  14. -40 ulelong 0x464D4520 Windows Enhanced Metafile (EMF) image data
  15. ->44 ulelong x version 0x%x.
  16. +#40 ulelong 0x464D4520 Windows Enhanced Metafile (EMF) image data
  17. +#>44 ulelong x version 0x%x.
  18. # If the description has a length greater than zero, it exists and is
  19. # found at offset (*64).
  20. ->64 ulelong >0 Description available at offset 0x%x
  21. ->>60 ulelong >0 (length 0x%x)
  22. +#>64 ulelong >0 Description available at offset 0x%x
  23. +#>>60 ulelong >0 (length 0x%x)
  24. # Note it would be better to print out the description, which is found
  25. # as below. Unfortunately the following only prints out the first couple
  26. # of characters instead of all the "description length"
  27. # number of characters -- indicated by the ulelong at offset 60.
  28. ->>(64.l) lestring16 >0 Description: %15.15s
  29. +#>>(64.l) lestring16 >0 Description: %15.15s
  30. # From: Alex Beregszaszi <alex@fsn.hu>
  31. 0 string COWD VMWare3