108-magic-remove-quicktime.dpatch 1.5 KB

1234567891011121314151617181920212223242526
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 108-magic-remove-quicktime.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: Disabled some QuickTime entries (ASCII words, closes: #366986, #308394).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/animation file-4.20/magic/Magdir/animation
  7. --- file-4.20.orig/magic/Magdir/animation 2007-01-14 18:47:21.000000000 +0000
  8. +++ file-4.20/magic/Magdir/animation 2007-03-27 12:23:14.000000000 +0000
  9. @@ -14,11 +14,11 @@
  10. >12 string cmov \b movie (fast start, compressed header)
  11. >12 string rmra \b multiple URLs
  12. 4 string mdat Apple QuickTime movie (unoptimized)
  13. -4 string wide Apple QuickTime movie (unoptimized)
  14. -4 string skip Apple QuickTime movie (modified)
  15. -4 string free Apple QuickTime movie (modified)
  16. +#4 string wide Apple QuickTime movie (unoptimized)
  17. +#4 string skip Apple QuickTime movie (modified)
  18. +#4 string free Apple QuickTime movie (modified)
  19. 4 string idsc Apple QuickTime image (fast start)
  20. -4 string idat Apple QuickTime image (unoptimized)
  21. +#4 string idat Apple QuickTime image (unoptimized)
  22. 4 string pckg Apple QuickTime compressed archive
  23. 4 string/B jP JPEG 2000 image
  24. 4 string ftyp ISO Media