203-magic-update-cow.dpatch 1.0 KB

123456789101112131415161718192021222324252627
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 203-magic-update-cow.dpatch by Matthew Palmer <mpalmer@debian.org>
  3. ##
  4. ## DP: Update COW magic from 2.0 to 3.0 (Closes: #283515, #319128).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/linux file-4.20/magic/Magdir/linux
  7. --- file-4.20.orig/magic/Magdir/linux 2006-11-25 18:36:10.000000000 +0000
  8. +++ file-4.20/magic/Magdir/linux 2007-03-27 16:33:53.000000000 +0000
  9. @@ -109,10 +109,12 @@
  10. 0 string Begin3 Linux Software Map entry text
  11. 0 string Begin4 Linux Software Map entry text (new format)
  12. -# From Matt Zimmerman
  13. -0 belong 0x4f4f4f4d User-mode Linux COW file
  14. ->4 belong x \b, version %d
  15. ->8 string >\0 \b, backing file %s
  16. +# From Matt Zimmerman, enhanced for v3 by Matthew Palmer
  17. +0 belong 0x4f4f4f4d User-mode Linux COW file
  18. +>4 belong <3 \b, version %d
  19. +>>8 string >\0 \b, backing file %s
  20. +>4 belong >2 \b, version %d
  21. +>>32 string >\0 \b, backing file %s
  22. ############################################################################
  23. # Linux kernel versions