210-magic-update-m4v.dpatch 1.3 KB

1234567891011121314151617181920212223242526272829
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 209-magic-update-m4v.dpatch by Nigel McNie <nigel@mcnie.name>
  3. ##
  4. ## DP: Detect m4v files as m4v instead of mp4 (Closes: #384018).
  5. @DPATCH@
  6. diff -Naurp file-4.23.orig/magic/Magdir/animation file-4.23/magic/Magdir/animation
  7. --- file-4.23.orig/magic/Magdir/animation 2007-11-08 00:28:03.000000000 +0000
  8. +++ file-4.23/magic/Magdir/animation 2008-01-12 16:42:17.000000000 +0000
  9. @@ -36,6 +36,7 @@
  10. >8 string mmp4 \b, MPEG v4 system, 3GPP Mobile
  11. >8 string avc1 \b, MPEG v4 system, 3GPP JVT AVC
  12. >8 string/B M4A \b, MPEG v4 system, iTunes AAC-LC
  13. +>8 string/B M4V \b, MPEG v4 system, iTunes AVC-LC
  14. >8 string/B M4P \b, MPEG v4 system, iTunes AES encrypted
  15. >8 string/B M4B \b, MPEG v4 system, iTunes bookmarked
  16. >8 string/B qt \b, Apple QuickTime movie
  17. diff -Naurp file-4.23.orig/magic/magic.mime file-4.23/magic/magic.mime
  18. --- file-4.23.orig/magic/magic.mime 2007-12-27 16:19:37.000000000 +0000
  19. +++ file-4.23/magic/magic.mime 2008-01-12 16:42:17.000000000 +0000
  20. @@ -672,6 +672,7 @@
  21. >8 string avc1 video/3gpp
  22. >8 string mmp4 video/mp4
  23. >8 string/B M4A audio/mp4
  24. +>8 string/B M4V video/mp4
  25. >8 string/B qt video/quicktime
  26. # The contributor claims:
  27. # I couldn't find a real magic number for these, however, this