211-magic-update-macintosh.dpatch 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 210-magic-update-macintosh.dpatch by Josef Spillner <2005@kuarepoti-dju.net>
  3. ##
  4. ## DP: Extend HFS+ partition table detection (Closes: #405313).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/macintosh file-4.20/magic/Magdir/macintosh
  7. --- file-4.20.orig/magic/Magdir/macintosh 2005-01-19 17:56:21.000000000 +0000
  8. +++ file-4.20/magic/Magdir/macintosh 2007-05-17 17:18:23.000000000 +0000
  9. @@ -321,7 +321,7 @@
  10. # cstring. Of course, partitions can contain more than four entries, but
  11. # what're you gonna do?
  12. 0x200 beshort 0x504D Apple Partition data
  13. ->0x2 beshort x block size: %d,
  14. +>0x2 beshort x (block size: %d):
  15. >0x230 string x first type: %s,
  16. >0x210 string x name: %s,
  17. >0x254 belong x number of blocks: %d,
  18. @@ -329,14 +329,22 @@
  19. >>0x430 string x second type: %s,
  20. >>0x410 string x name: %s,
  21. >>0x454 belong x number of blocks: %d,
  22. +>>0x600 beshort 0x504D
  23. +>>>0x630 string x third type: %s,
  24. +>>>0x610 string x name: %s,
  25. +>>>0x654 belong x number of blocks: %d,
  26. >>0x800 beshort 0x504D
  27. ->>>0x830 string x third type: %s,
  28. +>>>0x830 string x fourth type: %s,
  29. >>>0x810 string x name: %s,
  30. >>>0x854 belong x number of blocks: %d,
  31. >>>0xa00 beshort 0x504D
  32. ->>>>0xa30 string x fourth type: %s,
  33. +>>>>0xa30 string x fifth type: %s,
  34. >>>>0xa10 string x name: %s,
  35. >>>>0xa54 belong x number of blocks: %d
  36. +>>>0xc00 beshort 0x504D
  37. +>>>>0xc30 string x sixth type: %s,
  38. +>>>>0xc10 string x name: %s,
  39. +>>>>0xc54 belong x number of blocks: %d
  40. # AFAIK, only the signature is different
  41. 0x200 beshort 0x5453 Apple Old Partition data
  42. >0x2 beshort x block size: %d,