213-magic-update-pcp.dpatch 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 212-magic-update-pcp.dpatch by Werner Fink <werner@suse.de>
  3. ##
  4. ## DP: Correct PCP entries.
  5. @DPATCH@
  6. diff -Naurp file-4.23.orig/magic/Magdir/sgi file-4.23/magic/Magdir/sgi
  7. --- file-4.23.orig/magic/Magdir/sgi 2007-09-26 20:23:49.000000000 +0000
  8. +++ file-4.23/magic/Magdir/sgi 2008-01-12 16:47:49.000000000 +0000
  9. @@ -8,12 +8,17 @@
  10. 0 string PmNs PCP compiled namespace (V.0)
  11. 0 string PmN PCP compiled namespace
  12. >3 string >\0 (V.%1.1s)
  13. -3 lelong 0x84500526 PCP archive
  14. +#3 lelong 0x84500526 PCP archive
  15. +3 belong 0x84500526 PCP archive
  16. >7 byte x (V.%d)
  17. ->20 lelong -2 temporal index
  18. ->20 lelong -1 metadata
  19. ->20 lelong 0 log volume #0
  20. ->20 lelong >0 log volume #%ld
  21. +#>20 lelong -2 temporal index
  22. +#>20 lelong -1 metadata
  23. +#>20 lelong 0 log volume #0
  24. +#>20 lelong >0 log volume #%ld
  25. +>20 belong -2 temporal index
  26. +>20 belong -1 metadata
  27. +>20 belong 0 log volume #0
  28. +>20 belong >0 log volume #%ld
  29. >24 string >\0 host: %s
  30. 0 string PCPFolio PCP
  31. >9 string Version: Archive Folio
  32. @@ -30,6 +35,9 @@
  33. 0 string #pmlogger PCP pmlogger config
  34. >10 string Version
  35. >18 string >\0 (V%1.1s)
  36. +0 string #pmdahotproc PCP pmdahotproc config
  37. +>13 string Version
  38. +>21 string >\0 (V%-3.3s)
  39. 0 string PcPh PCP Help
  40. >4 string 1 Index
  41. >4 string 2 Text