214-magic-update-perl.dpatch 901 B

123456789101112131415161718192021
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 213-magic-update-perl.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: Make Perl script entries consistent (closes: #394523).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/perl file-4.20/magic/Magdir/perl
  7. --- file-4.20.orig/magic/Magdir/perl 2007-03-01 23:20:19.000000000 +0000
  8. +++ file-4.20/magic/Magdir/perl 2007-03-27 12:23:14.000000000 +0000
  9. @@ -9,8 +9,8 @@
  10. 0 string eval\ "exec\ /bin/perl perl script text
  11. 0 string/b #!\ /usr/bin/perl perl script text executable
  12. 0 string eval\ "exec\ /usr/bin/perl perl script text
  13. -0 string/b #!\ /usr/local/bin/perl perl script text
  14. -0 string eval\ "exec\ /usr/local/bin/perl perl script text executable
  15. +0 string/b #!\ /usr/local/bin/perl perl script text executable
  16. +0 string eval\ "exec\ /usr/local/bin/perl perl script text
  17. 0 string eval\ '(exit\ $?0)'\ &&\ eval\ 'exec perl script text