215-magic-update-sh.dpatch 862 B

12345678910111213141516171819
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 214-magic-update-sh.dpatch by Mark Hindley <mark@hindley.org.uk>
  3. ##
  4. ## DP: Changing sh identifier from Bourne to POSIX (Closes: #368613).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/commands file-4.20/magic/Magdir/commands
  7. --- file-4.20.orig/magic/Magdir/commands 2007-01-19 19:28:01.000000000 +0000
  8. +++ file-4.20/magic/Magdir/commands 2007-03-27 15:48:37.000000000 +0000
  9. @@ -3,7 +3,7 @@
  10. # commands: file(1) magic for various shells and interpreters
  11. #
  12. 0 string : shell archive or script for antique kernel text
  13. -0 string/b #!\ /bin/sh Bourne shell script text executable
  14. +0 string/b #!\ /bin/sh POSIX shell script text executable
  15. 0 string/b #!\ /bin/csh C shell script text executable
  16. # korn shell magic, sent by George Wu, gwu@clyde.att.com
  17. 0 string/b #!\ /bin/ksh Korn shell script text executable