302-magic-add-apple2.dpatch 1.2 KB

12345678910111213141516171819202122232425262728293031323334
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 303-magic-add-apple2.dpatch by Radek Vokal <rvokal@redhat.com>
  3. ##
  4. ## DP: Adds new magic for Apple Emulator 2IMG format.
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/apple file-4.20/magic/Magdir/apple
  7. --- file-4.20.orig/magic/Magdir/apple 2006-03-02 22:10:26.000000000 +0000
  8. +++ file-4.20/magic/Magdir/apple 2007-04-03 14:03:21.000000000 +0000
  9. @@ -10,6 +10,23 @@
  10. 0 belong 0x00051600 AppleSingle encoded Macintosh file
  11. 0 belong 0x00051607 AppleDouble encoded Macintosh file
  12. +# Type: Apple Emulator 2IMG format
  13. +# From: Radek Vokal <rvokal@redhat.com>
  14. +0 string 2IMG Apple ][ 2IMG Disk Image
  15. +>4 string XGS! \b, XGS
  16. +>4 string CTKG \b, Catakig
  17. +>4 string ShIm \b, Sheppy's ImageMaker
  18. +>4 string WOOF \b, Sweet 16
  19. +>4 string B2TR \b, Bernie ][ the Rescue
  20. +>4 string !nfc \b, ASIMOV2
  21. +>4 string x \b, Unknown Format
  22. +>0xc byte 00 \b, DOS 3.3 sector order
  23. +>>0x10 byte 00 \b, Volume 254
  24. +>>0x10 byte&0x7f x \b, Volume %u
  25. +>0xc byte 01 \b, ProDOS sector order
  26. +>>0x14 short x \b, %u Blocks
  27. +>0xc byte 02 \b, NIB data
  28. +
  29. # magic for Newton PDA package formats
  30. # from Ruda Moura <ruda@helllabs.org>
  31. 0 string package0 Newton package, NOS 1.x,