312-magic-add-luks.dpatch 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 313-magic-add-luks.dpatch by Anthon van der Neut <anthon@mnt.org>
  3. ##
  4. ## DP: New magic for the Linux Unified Key Setup (Closes: #394246).
  5. @DPATCH@
  6. diff -Naurp file-4.23.orig/magic/Magdir/luks file-4.23/magic/Magdir/luks
  7. --- file-4.23.orig/magic/Magdir/luks 1970-01-01 00:00:00.000000000 +0000
  8. +++ file-4.23/magic/Magdir/luks 2008-01-12 17:03:02.000000000 +0000
  9. @@ -0,0 +1,10 @@
  10. +# Type: Linux Unified Key Setup
  11. +# URL: http://luks.endorphin.org/spec
  12. +# From: Anthon van der Neut <anthon@mnt.org>
  13. +
  14. +0 string LUKS\xba\xbe LUKS encrypted file,
  15. +>6 beshort x ver %d
  16. +>8 string x [%s,
  17. +>40 string x %s,
  18. +>72 string x %s]
  19. +>168 string x UUID: %s
  20. diff -Naurp file-4.23.orig/magic/Makefile.am file-4.23/magic/Makefile.am
  21. --- file-4.23.orig/magic/Makefile.am 2008-01-12 17:03:36.000000000 +0000
  22. +++ file-4.23/magic/Makefile.am 2008-01-12 17:03:02.000000000 +0000
  23. @@ -121,6 +121,7 @@ Magdir/linux \
  24. Magdir/lisp \
  25. Magdir/llvm \
  26. Magdir/lua \
  27. +Magdir/luks \
  28. Magdir/mach \
  29. Magdir/macintosh \
  30. Magdir/magic \
  31. diff -Naurp file-4.23.orig/magic/Makefile.in file-4.23/magic/Makefile.in
  32. --- file-4.23.orig/magic/Makefile.in 2008-01-12 17:03:36.000000000 +0000
  33. +++ file-4.23/magic/Makefile.in 2008-01-12 17:03:02.000000000 +0000
  34. @@ -260,6 +260,7 @@ Magdir/linux \
  35. Magdir/lisp \
  36. Magdir/llvm \
  37. Magdir/lua \
  38. +Magdir/luks \
  39. Magdir/mach \
  40. Magdir/macintosh \
  41. Magdir/magic \