313-magic-add-lzma.dpatch 745 B

12345678910111213141516171819202122
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 314-magic-add-lzma.dpatch by Robert Millan <rmh@aybabtu.com>
  3. ##
  4. ## DP: New magic for the LZMA compression format (Closes: #364260).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/compress file-4.20/magic/Magdir/compress
  7. --- file-4.20.orig/magic/Magdir/compress 2007-04-03 13:10:23.000000000 +0000
  8. +++ file-4.20/magic/Magdir/compress 2007-04-03 13:15:02.000000000 +0000
  9. @@ -174,6 +174,11 @@
  10. >6 byte x version %d
  11. >7 byte x \b.%d
  12. +# Type: LZMA
  13. +# URL: http://www.7-zip.org/sdk.html
  14. +# From: Robert Millan <rmh@aybabtu.com>
  15. +0 string ]\000\000\200\000\377\377\377\377\377\377\377\377 LZMA compressed data
  16. +
  17. # AFX compressed files (Wolfram Kleff)
  18. 2 string -afx- AFX compressed file data