332-magic-add-svg.dpatch 768 B

1234567891011121314151617181920
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 327-magic-add-svg.dpatch by Noel Torres <tecnico@ejerciciosresueltos.com>
  3. ##
  4. ## DP: Adds magic for SVG (Closes: #417331).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/sgml file-4.20/magic/Magdir/sgml
  7. --- file-4.20.orig/magic/Magdir/sgml 2007-01-19 21:09:07.000000000 +0000
  8. +++ file-4.20/magic/Magdir/sgml 2007-05-17 16:54:52.000000000 +0000
  9. @@ -33,3 +33,9 @@
  10. 0 string #\ HTTP\ Cookie\ File Web browser cookie text
  11. 0 string #\ Netscape\ HTTP\ Cookie\ File Netscape cookie text
  12. 0 string #\ KDE\ Cookie\ File Konqueror cookie text
  13. +
  14. +# Type: SVG Vectorial Graphics
  15. +# From: Noel Torres <tecnico@ejerciciosresueltos.com>
  16. +0 string \<?xml\ version="
  17. +>15 string >\0
  18. +>>23 regex .*\<svg SVG Scalable Vector Graphics image