cherry-pick.FILE5_30-38-gfd42e119.if-we-could-not-read-a-field-set-it-to-0-found-by-oss-fuzz.patch 421 B

123456789101112131415
  1. Subject: If we could not read a field, set it to 0; found by oss-fuzz
  2. Origin: FILE5_30-38-gfd42e119
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Thu Apr 6 19:20:35 2017 +0000
  5. --- a/src/cdf.c
  6. +++ b/src/cdf.c
  7. @@ -1039,6 +1039,7 @@
  8. break;
  9. default:
  10. unknown:
  11. + memset(&inp[i].pi_val, 0, sizeof(inp[i].pi_val));
  12. DPRINTF(("Don't know how to deal with %x\n",
  13. inp[i].pi_type));
  14. break;