cherry-pick.revert.FILE5_37-59-g24c9c086.revert-pr-93-iaeiaeiaeiae-do-as-the-comment-says-and-count-as-dynamically-linked.patch 921 B

12345678910111213141516171819202122232425262728
  1. Subject: Revert "PR/93: iaeiaeiaeiae: Do as the comment says, and count as dynamically linked (...)"
  2. Origin: FILE5_37-59-g24c9c086 <https://github.com/file/file/commit/FILE5_37-59-g24c9c086>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Tue Jul 23 21:33:45 2019 +0000
  5. Bug-Debian: https://bugs.debian.org/948269
  6. PR/93: iaeiaeiaeiae: Do as the comment says, and count as dynamically linked
  7. only the binaries that have an interpreter, not the ones that contain a
  8. dynamic section. Fixes issue with -static-pie from gcc-9.x
  9. --- a/src/readelf.c
  10. +++ b/src/readelf.c
  11. @@ -1638,6 +1638,7 @@
  12. /* Things we can determine before we seek */
  13. switch (xph_type) {
  14. case PT_DYNAMIC:
  15. + linking_style = "dynamically";
  16. doread = 1;
  17. break;
  18. case PT_NOTE:
  19. @@ -1653,7 +1654,6 @@
  20. }
  21. /*FALLTHROUGH*/
  22. case PT_INTERP:
  23. - linking_style = "dynamically";
  24. doread = 1;
  25. break;
  26. default: