cherry-pick.FILE5_39-9-g85b7ab83.include-alternate-format-to-the-list-of-uninteresting-formats.patch 598 B

12345678910111213141516171819
  1. Subject: Include # (alternate format) to the list of uninteresting formats (...)
  2. Origin: FILE5_39-9-g85b7ab83 <https://github.com/file/file/commit/FILE5_39-9-g85b7ab83>
  3. Upstream-Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Thu Jun 25 16:52:48 2020 +0000
  5. Include # (alternate format) to the list of uninteresting formats
  6. Reported by Werner Fink
  7. --- a/src/funcs.c
  8. +++ b/src/funcs.c
  9. @@ -93,7 +93,7 @@
  10. if (*++p == '%')
  11. continue;
  12. // Skip uninteresting.
  13. - while (strchr("0.'+- ", *p) != NULL)
  14. + while (strchr("#0.'+- ", *p) != NULL)
  15. p++;
  16. if (*p == '*') {
  17. if (msg)