local.allow-syscalls-by-fakeroot.patch 841 B

12345678910111213141516171819202122232425262728293031323334
  1. Subject: Allow syscalls make by libfakeroot
  2. Upstream-Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Last-Update: 2019-07-22
  4. Bug-Debian: https://bugs.debian.org/932762
  5. --- a/src/seccomp.c
  6. +++ b/src/seccomp.c
  7. @@ -181,6 +181,7 @@
  8. #ifdef __NR_getdents64
  9. ALLOW_RULE(getdents64);
  10. #endif
  11. + ALLOW_RULE(getpid);
  12. #ifdef FIONREAD
  13. // called in src/compress.c under sread
  14. ALLOW_IOCTL_RULE(FIONREAD);
  15. @@ -198,6 +199,9 @@
  16. ALLOW_RULE(mmap2);
  17. ALLOW_RULE(mprotect);
  18. ALLOW_RULE(mremap);
  19. + ALLOW_RULE(msgget);
  20. + ALLOW_RULE(msgrcv);
  21. + ALLOW_RULE(msgsnd);
  22. ALLOW_RULE(munmap);
  23. #ifdef __NR_newfstatat
  24. ALLOW_RULE(newfstatat);
  25. @@ -211,6 +215,8 @@
  26. ALLOW_RULE(rt_sigprocmask);
  27. ALLOW_RULE(rt_sigreturn);
  28. ALLOW_RULE(select);
  29. + ALLOW_RULE(semget);
  30. + ALLOW_RULE(semop);
  31. ALLOW_RULE(stat);
  32. ALLOW_RULE(stat64);
  33. ALLOW_RULE(sysinfo);