12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758 |
- Authors:
- Michael Piefel <piefel@debian.org>,
- Judit Foglszinger <fgrfgr@freenet.de>
- Description:
- No longer includes Localstuff in /usr/share/misc/magic, local definitions
- should go to /etc/magic.
- --- a/magic/Header
- +++ b/magic/Header
- @@ -1,5 +1,6 @@
- # Magic data for file(1) command.
- -# Format is described in magic(files), where:
- -# files is 5 on V7 and BSD, 4 on SV, and ?? on SVID.
- +# Format is described in in magic(5).
- # Don't edit this file, edit /etc/magic or send your magic improvements
- -# to the maintainers, at file@mx.gw.com
- +# to the upstream maintainers, at file@mx.gw.com
- +# or send your suggested inclusions
- +# as a wishlist bug against file (using the reportbug utility).
- --- /dev/null
- +++ b/magic/magic.local
- @@ -0,0 +1,3 @@
- +# Magic local data for file(1) command.
- +# Insert here your local magic data. Format is described in magic(5).
- +
- --- a/src/apprentice.c
- +++ b/src/apprentice.c
- @@ -448,7 +448,7 @@
- #ifndef COMPILE_ONLY
- map = apprentice_map(ms, fn);
- if (map == NULL) {
- - if (ms->flags & MAGIC_CHECK)
- + if (ms->flags & MAGIC_CHECK && strcmp("/etc/magic", fn) != 0)
- file_magwarn(ms, "using regular magic file `%s'", fn);
- map = apprentice_load(ms, fn, action);
- if (map == NULL)
- --- a/src/Makefile.am
- +++ b/src/Makefile.am
- @@ -4,7 +4,7 @@
-
- bin_PROGRAMS = file
-
- -AM_CPPFLAGS = -DMAGIC='"$(MAGIC)"'
- +AM_CPPFLAGS = -DMAGIC='"/etc/magic:$(MAGIC)"'
- AM_CFLAGS = $(CFLAG_VISIBILITY) @WARNINGS@
-
- libmagic_la_SOURCES = magic.c apprentice.c softmagic.c ascmagic.c \
- --- a/src/Makefile.in
- +++ b/src/Makefile.in
- @@ -329,7 +329,7 @@
- MAGIC = $(pkgdatadir)/magic
- lib_LTLIBRARIES = libmagic.la
- include_HEADERS = magic.h
- -AM_CPPFLAGS = -DMAGIC='"$(MAGIC)"'
- +AM_CPPFLAGS = -DMAGIC='"/etc/magic:$(MAGIC)"'
- AM_CFLAGS = $(CFLAG_VISIBILITY) @WARNINGS@
- libmagic_la_SOURCES = magic.c apprentice.c softmagic.c ascmagic.c \
- encoding.c compress.c is_tar.c readelf.c print.c fsmagic.c \
|