local.mention-posixly-correct-dependent-behaviour-in-usage-message.patch 678 B

12345678910111213141516171819
  1. Description: Mention POSIXLY_CORRECT dependent behaviour in usage message
  2. Author: Daniel Baumann <mail@daniel-baumann.ch>
  3. Bug-Debian: https://bugs.debian.org/576679
  4. Last-Update: 2016-06-27
  5. --- a/src/file_opts.h
  6. +++ b/src/file_opts.h
  7. @@ -59,9 +59,9 @@
  8. " list magic strength\n")
  9. #ifdef S_IFLNK
  10. OPT('L', "dereference", 0, 1,
  11. - " follow symlinks")
  12. + " follow symlinks (default if POSIXLY_CORRECT is set)")
  13. OPT('h', "no-dereference", 0, 2,
  14. - " don't follow symlinks")
  15. + " don't follow symlinks (default if POSIXLY_CORRECT is not set)")
  16. #endif
  17. OPT('n', "no-buffer", 0, 0,
  18. " do not buffer output\n")