local.mention-posixly-correct-dependent-behaviour-in-usage-message.patch 871 B

123456789101112131415161718
  1. Description: Mention POSIXLY_CORRECT dependent behaviour in usage message
  2. Author: Daniel Baumann <mail@daniel-baumann.ch>
  3. Bug-Debian: https://bugs.debian.org/576679
  4. Last-Update: 2015-09-18
  5. --- a/src/file_opts.h
  6. +++ b/src/file_opts.h
  7. @@ -36,8 +36,8 @@
  8. OPT('k', "keep-going", 0, " don't stop at the first match\n")
  9. OPT('l', "list", 0, " list magic strength\n")
  10. #ifdef S_IFLNK
  11. -OPT('L', "dereference", 0, " follow symlinks (default)\n")
  12. -OPT('h', "no-dereference", 0, " don't follow symlinks\n")
  13. +OPT('L', "dereference", 0, " follow symlinks (default if POSIXLY_CORRECT is set)\n")
  14. +OPT('h', "no-dereference", 0, " don't follow symlinks (default if POSIXLY_CORRECT is not set)\n")
  15. #endif
  16. OPT('n', "no-buffer", 0, " do not buffer output\n")
  17. OPT('N', "no-pad", 0, " do not pad output\n")