206-magic-update-elf-b.dpatch 1.0 KB

123456789101112131415161718192021222324252627282930
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 206-magic-update-elf-b.dpatch by Robert Millan <rmh@aybabtu.com>
  3. ##
  4. ## DP: New magic for OpenRISC binary format (Closes: #316076).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/elf file-4.20/magic/Magdir/elf
  7. --- file-4.20.orig/magic/Magdir/elf 2006-12-18 14:14:34.000000000 +0000
  8. +++ file-4.20/magic/Magdir/elf 2007-03-27 16:47:26.000000000 +0000
  9. @@ -99,6 +99,9 @@
  10. >>18 leshort 62 x86-64,
  11. >>18 leshort 75 Digital VAX,
  12. >>18 leshort 88 Renesas M32R,
  13. +>>18 leshort 92 OpenRISC,
  14. +>>18 leshort 0x3426 OpenRISC (obsolete),
  15. +>>18 leshort 0x8472 OpenRISC (obsolete),
  16. >>18 leshort 94 Tensilica Xtensa,
  17. >>18 leshort 97 NatSemi 32k,
  18. >>18 leshort 0x9026 Alpha (unofficial),
  19. @@ -193,6 +196,9 @@
  20. >>18 beshort 73 Cray NV1,
  21. >>18 beshort 75 Digital VAX,
  22. >>18 beshort 88 Renesas M32R,
  23. +>>18 leshort 92 OpenRISC,
  24. +>>18 leshort 0x3426 OpenRISC (obsolete),
  25. +>>18 leshort 0x8472 OpenRISC (obsolete),
  26. >>18 beshort 94 Tensilica Xtensa,
  27. >>18 beshort 97 NatSemi 32k,
  28. >>18 beshort 0x9026 Alpha (unofficial),