307-magic-add-dds.dpatch 1.1 KB

12345678910111213141516171819202122
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 307-magic-add-dds.dpatch from Morten Hustveit <morten@debian.org>
  3. ##
  4. ## DP: New magic for DirectDraw Surface files (Closes: #276133).
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/msdos file-4.20/magic/Magdir/msdos
  7. --- file-4.20.orig/magic/Magdir/msdos 2007-01-19 19:35:20.000000000 +0000
  8. +++ file-4.20/magic/Magdir/msdos 2007-04-03 16:35:15.000000000 +0000
  9. @@ -619,3 +619,11 @@
  10. # from http://filext.com by Derek M Jones <derek@knosof.co.uk>
  11. 0 string \xD0\xCF\x11\xE0\xA1\xB1\x1A\xE1\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x3E\x00\x03\x00\xFE\xFF Microsoft Installer
  12. 0 string \320\317\021\340\241\261\032\341 Microsoft Office Document
  13. +
  14. +# Type: Microsoft DirectDraw Surface
  15. +# URL: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/directx9_c/directx/graphics/reference/DDSFileReference/ddsfileformat.asp
  16. +# From: Morten Hustveit <morten@debian.org>
  17. +0 string DDS\040\174\000\000\000 Microsoft DirectDraw Surface (DDS),
  18. +>16 lelong >0 %hd x
  19. +>12 lelong >0 %hd,
  20. +>84 string x %.4s