328-magic-add-xen.dpatch 689 B

123456789101112131415161718192021
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 328-magic-add-xen.dpatch by Radek Vokal <rvokal@redhat.com>
  3. ##
  4. ## DP: xen patch, recognizes Xen saved domain
  5. @DPATCH@
  6. diff -Naur file-4.20.orig/magic/Magdir/linux file-4.20/magic/Magdir/linux
  7. --- file-4.20.orig/magic/Magdir/linux 2006-11-25 18:36:10.000000000 +0000
  8. +++ file-4.20/magic/Magdir/linux 2007-04-03 13:49:17.000000000 +0000
  9. @@ -236,3 +236,10 @@
  10. >20 lelong 1 MLS
  11. >24 lelong x %d symbols
  12. >28 lelong x %d ocons
  13. +
  14. +# Type: Xen, the virtual machine monitor
  15. +# From: Radek Vokal <rvokal@redhat.com>
  16. +0 string LinuxGuestRecord Xen saved domain
  17. +#>2 regex \(name\ [^)]*\) %s
  18. +>20 search/256 (name (name
  19. +>>&1 string x %s...)