903-file-localmagic.dpatch 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 903-magic-local.dpatch by Michael Piefel <piefel@debian.org>
  3. ##
  4. ## DP: No longer includes Localstuff in /usr/share/misc/magic. Local definitions
  5. ## DP: should go to /etc/magic.
  6. @DPATCH@
  7. diff -Naur file-4.20.orig/magic/magic.local file-4.20/magic/magic.local
  8. --- file-4.20.orig/magic/magic.local 1970-01-01 00:00:00.000000000 +0000
  9. +++ file-4.20/magic/magic.local 2007-03-27 12:23:14.000000000 +0000
  10. @@ -0,0 +1,3 @@
  11. +# Magic local data for file(1) command.
  12. +# Insert here your local magic data. Format is described in magic(5).
  13. +
  14. diff -Naur file-4.20.orig/src/Makefile.am file-4.20/src/Makefile.am
  15. --- file-4.20.orig/src/Makefile.am 2007-01-12 17:40:53.000000000 +0000
  16. +++ file-4.20/src/Makefile.am 2007-03-27 12:23:14.000000000 +0000
  17. @@ -5,7 +5,7 @@
  18. bin_PROGRAMS = file
  19. -AM_CPPFLAGS = -DMAGIC='"$(MAGIC)"'
  20. +AM_CPPFLAGS = -DMAGIC='"/etc/magic:$(MAGIC)"'
  21. libmagic_la_SOURCES = magic.c apprentice.c softmagic.c ascmagic.c \
  22. compress.c is_tar.c readelf.c print.c fsmagic.c \
  23. diff -Naur file-4.20.orig/src/Makefile.in file-4.20/src/Makefile.in
  24. --- file-4.20.orig/src/Makefile.in 2007-03-01 23:21:09.000000000 +0000
  25. +++ file-4.20/src/Makefile.in 2007-03-27 12:23:14.000000000 +0000
  26. @@ -196,7 +196,7 @@
  27. lib_LTLIBRARIES = libmagic.la
  28. include_HEADERS = magic.h
  29. EXTRA_DIST = test.c
  30. -AM_CPPFLAGS = -DMAGIC='"$(MAGIC)"'
  31. +AM_CPPFLAGS = -DMAGIC='"/etc/magic:$(MAGIC)"'
  32. libmagic_la_SOURCES = magic.c apprentice.c softmagic.c ascmagic.c \
  33. compress.c is_tar.c readelf.c print.c fsmagic.c \
  34. funcs.c file.h names.h patchlevel.h readelf.h tar.h apptype.c
  35. diff -Naur file-4.20.orig/magic/Header file-4.20/magic/Header
  36. --- file-4.20.orig/magic/Header 2000-08-05 17:36:46.000000000 +0000
  37. +++ file-4.20/magic/Header 2007-03-27 12:23:14.000000000 +0000
  38. @@ -1,5 +1,5 @@
  39. -# Magic
  40. # Magic data for file(1) command.
  41. -# Machine-generated from src/cmd/file/magdir/*; edit there only!
  42. -# Format is described in magic(files), where:
  43. -# files is 5 on V7 and BSD, 4 on SV, and ?? in the SVID.
  44. +# Format is described in magic(5).
  45. +# Don't edit this file, edit /etc/magic or send your suggested inclusions to
  46. +# this file as a wishlist bug against file (using the reportbug utility).
  47. +