201-magic-update-mp3.dpatch 733 B

12345678910111213141516171819
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 201-magic-update-mp3.dpatch by Werner Fink <werner@suse.de>
  3. ##
  4. ## DP: Fixes regressions with mp3 files (Closes: #480683, #481377).
  5. @DPATCH@
  6. diff -Naurp file-4.24.orig/magic/Magdir/animation file-4.24/magic/Magdir/animation
  7. --- file-4.24.orig/magic/Magdir/animation 2008-05-04 14:12:49.000000000 +0000
  8. +++ file-4.24/magic/Magdir/animation 2008-05-21 09:23:29.000000000 +0000
  9. @@ -276,7 +276,7 @@
  10. # modified by Joerg Jenderek
  11. # GRR the original test are too common for many DOS files
  12. # so don't accept as MP3 until we've tested the rate
  13. -0 beshort&0xFFFE
  14. +0 beshort&0xFFFE 0xFFFA
  15. # rates
  16. >2 byte&0xF0 0x10 MPEG ADTS, layer III, v1, 32 kbps
  17. !:mime audio/mpeg