206-magic-update-bash.dpatch 861 B

123456789101112131415161718192021
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 206-magic-update-bash.dpatch
  3. ##
  4. ## DP: Add another shebang path for bash.
  5. @DPATCH@
  6. diff -Naurp file.orig/magic/Magdir/commands file/magic/Magdir/commands
  7. --- file.orig/magic/Magdir/commands 2008-06-13 14:56:16.000000000 +0200
  8. +++ file/magic/Magdir/commands 2008-06-13 14:57:49.000000000 +0200
  9. @@ -59,6 +59,10 @@
  10. # bash shell magic, from Peter Tobias (tobias@server.et-inf.fho-emden.de)
  11. 0 string/b #!\ /bin/bash Bourne-Again shell script text executable
  12. !:mime application/x-shellscript
  13. +0 string/b #!\ /usr/bin/bash Bourne-Again shell script text executable
  14. +!:mime application/x-shellscript
  15. +0 string/b #!\ /usr/local/bash Bourne-Again shell script text executable
  16. +!:mime application/x-shellscript
  17. 0 string/b #!\ /usr/local/bin/bash Bourne-Again shell script text executable
  18. !:mime application/x-shellscript